Problem assigning Elastic IP to VPC instances

John B's Avatar

John B

13 Sep, 2012 05:36 PM

Hello all,

I'm currently experiencing an issue assigning an Elastic IP address to any instances running in our VPC through the ylastic interface. I don't seem to have this problem when I perform the same action through the regular AWS website management console. If I attempt to assign a free IP address to one of our instances I get one of the following two error messages depending on how I do it:

Error associating elastic IP with instance: InvalidInstanceID: The instance 'i-c23172b8' belongs to a VPC. (I get this error in the EC2 section)

You cannot associate this elastic ip address as you do not have any VPC instances running in Virginia. (I get this error in the VPC section)

I've checked over and over again, and both the EIP and the instance itself are in Virginia. They are both assigned to the VPC. I've tried this with different EIPs and instances with the same result. Like I said, I was able to do this through the standard AWS web management console so I believe it may be a bug or maybe I'm doing something incorrectly in the ylastic interface.

Thanks in advance for any help.

  1. Support Staff 1 Posted by Ylastic on 13 Sep, 2012 08:51 PM

    Ylastic's Avatar

    This sounds like a bug on our side. Will get this looked into. Will ping you if we need any further info.

    thanks!

  2. 2 Posted by vineeth on 13 Feb, 2013 10:19 AM

    vineeth's Avatar

    I have problem

    Where one VPC will have 2 subnet
    And have created an subnet where i tried to link with the elastic IP and i am not able to view the instances from the drop down box only the EC2 instances are showed

    Can you suggest me an suloution for this

    Thanks awaiting for your response

  3. Ylastic closed this discussion on 08 Aug, 2014 02:17 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac