EBS instances backup task fails with wrong instance id in error message

Roman Belov's Avatar

Roman Belov

07 May, 2014 03:27 PM

Hi There,

We have several scheduled tasks set to "Backup All EBS instances with tag xxx" which fails with following error:
Error: The image id '[ami-c9c8cdbd]' does not exist...
Thing is that for this specific task where we get this error, we have no instances with such ami id - ami-c9c8cdbd.
I have 2 instances with the tag listed in this rule - both has different ami id from listed in error and I can run manual backup from Ylastic for both of them and everythiong works.

This is started on 4th of May and the problem is consistent since then.

Please advice.

Thanks.

  1. Support Staff 1 Posted by Ylastic on 07 May, 2014 04:02 PM

    Ylastic's Avatar

    Will look into this and update you.

    thanks

  2. Support Staff 2 Posted by Ylastic on 07 May, 2014 10:54 PM

    Ylastic's Avatar

    Is this a windows instance being backed up?

    thanks!

  3. 3 Posted by Roman Belov on 08 May, 2014 05:45 AM

    Roman Belov's Avatar

    No, all these 3 different backup tasks where I have this problem are for Linux instances (Debian/Ubuntu various versions).
    I had tried to delete one of these tasks and recreate it from scratch - it doesn't helps and the error message for new task shows same incorrect ami id as it was with original backup job.
    At the same time ami id I see on EC2 instances list in Ylastic is the right one.
    So it looks like such backup task gets wrong ami id.
    But this wrong ami id is persistent, even after task deletion and recreation from the scratch and even when I change the tag pattern slightly, to be sure it will need to search for instances with the new tag pattern.

  4. 4 Posted by Roman Belov on 08 May, 2014 07:11 AM

    Roman Belov's Avatar

    I had just figured out that we have similar issue on our second AWS account - this time with Windows 2012 instance.
    And, for unknown reason, we do not have any notification for issues here, although for the tasks failures on first account we do get notified every time.
    Note that in both accounts there are additional backup tasks setup in the same way which continue to work just fine.
    We need this issue resolved fast - it becomes too dangerous to use Ylastic for AWS instances backup!!!

  5. 5 Posted by Adam Spotton on 10 May, 2014 06:10 PM

    Adam Spotton's Avatar

    I am seeing this same error for the two accounts that I have with Ylastic - it just started recently. In both Ylastic accounts, I'm using the "Backup all EBS instances whose name tag contains" option and sometimes it works and sometimes I get an email with the following message:

    "Scheduled backup of EBS instances failed - The image id '[ami-XXXXXXX]' does not exist"

    Is there a resolution for this coming soon? We keep getting email spammed by these failing tasks.

    Thanks,
    Adam

  6. Support Staff 6 Posted by Ylastic on 11 May, 2014 07:11 PM

    Ylastic's Avatar

    Fixed. The issue is that EC2 is returning an AMI not found when we check the AMI status immediately after creating it. Added a wait for a few seconds before we do the first check for the state of the created AMI. Never had to this before. Maybe somethings changed on the EC2 side.

    If you still get this error please let me know.

    thanks!

  7. 7 Posted by Roman Belov on 12 May, 2014 05:44 AM

    Roman Belov's Avatar

    Sad, but it is not fixed yet and I still getting following errors:

    Ylastic Tasks [email blocked]

    8:08 AM (1 minute ago)

    to me
    Scheduled backup of EBS instances failed for task [Domnova UK backup] in account [xxxxxxxx] - The image id '[ami-c9c8cdbd]' does not exist

    • The Ylastic Team

    More than that, if till now we had only 3 such a failing tasks on this account, today we got same problem with a forth one, although I am not sure whether it is a result of your changes.

    This task includes only one instance which should be backup in UK region and its ami id is ami-f6cefe82.
    Manual backup of the same instance from Ylastic does works nomally, which means that AWS return prroper ami id and proper status when you check it performing manual backup and this operation does not require any wait.

    Looks like EC2 returned wrong status just cause it was just asked about wrong instance.
    In my problem report I mentioned that the ami id in the error IS NOT the ami is of the instance this task supposed to backup.
    Quote: "Thing is that for this specific task where we get this error, we have no instances with such ami id - ami-c9c8cdbd."

    I could be wrong, but for me the problem seems to be related to the way Scheduled backup task identifies the instances it should backup - here Ylastic gets wrong instance ids for some specific instances and request of status for that wrong instance id returns AWS responce that such ami id does not exists.
    And, last point is that those wrong ami id's are permanent - when I delete and recreate this task from the scratch and which supposed to backup only instance ami-f6cefe82, I still get the error stating that "image id '[ami-c9c8cdbd]' does not exist"

    Thanks!

  8. 8 Posted by Adam Spotton on 13 May, 2014 01:54 PM

    Adam Spotton's Avatar

    What you did the other day has worked for us, we haven't received any more failing tasks due to the AMI not found error.

    Thanks!

  9. 9 Posted by Roman Belov on 13 May, 2014 02:52 PM

    Roman Belov's Avatar

    Yes, the issue seems to be resolved starting from today on both accounts where we had it.

    Thanks,
    Roman

  10. Ylastic closed this discussion on 08 Aug, 2014 02:54 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac